Posts Tagged ‘Bobj is undefined’

Bobj is undefined – Crystal Reports

March 19, 2012

Hello All,

If you have been working with Crystal Reports and I could bet at least once you might faced the issue “Bobj” is undefined . This is most common error in using crystal reports. Recently I have faced this issue when I try to solve another technical issue on the crystal report.

At least from my experience and users experience in internet, “bobj” is one of well-known problem with CR.  Crystal reports products naming convention is another pain. It is bit difficult to understand the CR products and features from their naming . Lets not worry about that now. Coming to the issue in hand, I am using Visual studio 2010, IIS7.0, Windows 2008 server and CR2008. I want to upgrade CR 2008 with latest SP5. So I have uninstalled the setup and rebooted the server and again installed the fresh version of SP5 full download. Here is link for all downloads of CR.

After un-installation of previous version, I forgot to delete all the CR folders , which caused lot of headache and I ran to “Bobj’ undefined issue and some of the folders are not accessible etc. So finally cleaned up again and deleted all the left over folders and rebooted. Installed SP5 again. The reports started working fine in the deployed link. I mean we have web application which is published in the machine and reports are working. Here I have faced one more issue, though not sure about the cause, when I generate a report, I got an error message “Unable to connect to Database…” ORA code ( I forgot the exact code) . In the .rpt files, I have used many database connections which is the concern. I have deleted all the unwanted connnections and reports are working fine from the same machine.

Now, real challenge started for me, when the application is accessed from outside, reports are showing “BobJ” is undefined error. I could not figure out the reason for this. I was under assumption that if reports accessed from IIS then it accessed from everywhere in the same network. But it was not the case. In order find the issue, I have gone through some of the forums .. here is main link . This really helped me in fixing the issue. This blog post is extensive enough to help to fix the issue. Let me write a solution which worked for my case.

Issue: Missing “crystalreportviewers12” folder in the C:\inetpub\wwwroot\aspnet_client\system_web\4_0_30319.

Fix : Copy the entire ‘crystalreportviewers12’ from crystal report installed path. “D:\Program Files\Common\4.0” to C:\inetpub\..

This is helps in resolving the issue of accessing the crystal reports from the web application outside the network.

Quick check list for this issue:

1. Check CR is installed correctly. Delete all CR folders after un-installation. Especially under IIS. (C:\inetpub\wwwroot)

2. Install complete version of CR’s.

3. Check whether CR web site is created under IIS.

4. Check for missing folder C:\inetpub\wwwroot\aspnet_client\system_web\4_0_30319

5. Under Application Pools – Enable 32 Bit applications to TRUE (if it is integrated mode)

Choosing right product is important SDK is very important for crystal reports. Here is link for choosing SDK.

Hope this information really helps to users on this specific case.

 

 

Advertisements